hd 2123 An easy problem

 <h1 style="COLOR: #1a5cc8">An easy problem</h1><span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;FONT-WEIGHT: bold">Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5346    Accepted Submission(s): 3723
</span></strong></span>

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the i<sup>th</sup> row and j<sup>th</sup> column should be the product(乘積) of i and j.</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">For each test case, print out the multiply table.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="FONT-FAMILY: Courier New,Courier,monospace">2
1
4</div>
 

Sample Output
1 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16
Hint
There is no blank space at the end of each line.
 

Author
XHD
 

Source
 


 
#include<stdio.h>
int main()
{
    int t,n,i,j;
    while(scanf("%d",&t)!=EOF)
    {
      while(t--)
      {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
         if(j!=n)
         printf("%d ",i*j);
         else
         printf("%d\n",i*j);
                         }
                }
                              }
return 0;    
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章