例題6-8 Tree UVa548

題目描述:
You are to determine the value of the leaf node in a given binary tree that is the terminal node of a
path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values
of nodes along that path.
Input
The input file will contain a description of the binary tree given as the inorder and postorder traversal
sequences of that tree. Your program will read two line (until end of file) from the input file. The first
line will contain the sequence of values associated with an inorder traversal of the tree and the second
line will contain the sequence of values associated with a postorder traversal of the tree. All values
will be different, greater than zero and less than 10000. You may assume that no binary tree will have
more than 10000 nodes or less than 1 node.
Output
For each tree description you should output the value of the leaf node of a path of least value. In the
case of multiple paths of least value you should pick the one with the least value on the terminal node.
Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255
Sample Output
1
3
255
整體思路:
1.二叉樹建立過程:我們知道後序遍歷的最後一個元素就是根,再從中序遍歷中將這個元素找出來,然後遞歸即可。
2.權值最小: dfs遍歷即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <sstream>
using namespace std;
const int maxn=10000+10;
int n;
int in_order[maxn],post_order[maxn],lch[maxn],rch[maxn];
bool read(int *a){//輸入函數參見劉汝佳紫書第二版
    string line;
    while(!getline(cin,line))
        return false;
    stringstream ss(line);
    n=0;
    int x;
    while(ss >> x)
        a[n++]=x;
    return n>0;
}
int build(int L1,int R1,int L2,int R2){
    if(L1>R1)return 0;
    int root=post_order[R2];
    int p=L1;
    while(in_order[p]!=root){
        p++;
    }
    int cnt=p-L1;//遞歸建樹
    lch[root]=build(L1,p-1,L2,L2+cnt-1);
    rch[root]=build(p+1,R1,L2+cnt,R2-1);
    return root;
}
int best,best_sum;
void dfs(int u,int sum){
    sum+=u;
    if(!lch[u]&&!rch[u]){//葉子
        if(sum<best_sum||(sum==best_sum&&u<best)){
            best=u;
            best_sum=sum;
        }
    }
    if(lch[u])dfs(lch[u],sum);
    if(rch[u])dfs(rch[u],sum);
}
int main(){
    while(read(in_order)){
        read(post_order);
        build(0,n-1,0,n-1);
        best_sum=1000000000;
        dfs(post_order[n-1],0);
        printf("%d\n",best);
    }
return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章