Insert or Merge(25 分)

7-13 Insert or Merge(25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6
#include<iostream>
using namespace std;
void Merge(int sequence1[],int l,int r,int rend,int temp[]){
	int lend=r-1;
	int s=l;
	while(l<=lend&&r<=rend){
		if(sequence1[l]<sequence1[r]) temp[s++]=sequence1[l++];
		else temp[s++]=sequence1[r++];
	}
	while(l<=lend) temp[s++]=sequence1[l++];
	while(r<=rend) temp[s++]=sequence1[r++];
}
int main(){
	int N;
	int flag=1;//Insertion_sort
	cin>>N;
	int sequence[N];
	int sequence1[N];
	for(int i=0;i<N;i++)
	cin>>sequence[i];
	for(int i=0;i<N;i++)
	cin>>sequence1[i];
	int i,j;
	for(j=0;j<N-1;j++)
	if(sequence1[j]>sequence1[j+1]) break;
	int sign=j;
	for(j=j+1;j<N;j++)
	if(sequence[j]!=sequence1[j]) flag=0;//Merge_sort
	if(flag==1){
		cout<<"Insertion Sort"<<endl;
		int temp=sequence1[sign+1];
		for(i=sign+1;i>=0;i--)
		if(temp<sequence1[i-1]) 
		sequence1[i]=sequence1[i-1];
		else break;
		sequence1[i]=temp;
		int tag=0;
		for( i=0;i<N;i++){
			if(tag++==0) cout<<sequence1[i];
			else cout<<" "<<sequence1[i];
		}
	}
	else{
		int tag=1;
		cout<<"Merge Sort"<<endl;
		int length;
		for(length=2;length<=N;length*=2){
		for(i=length-1;i<N-1;i+=2*length)
		if(sequence1[i]>sequence1[i+1])
		{tag=0; break;}
		if(tag==0) break;
		}
		int temp[N];
	    for(i=0;i<N-2*length;i+=2*length)
	    Merge(sequence1,i,i+length,i+2*length-1,temp);
	    if(i+length<N)
	    Merge(sequence1,i,i+length,N-1,temp);
	    else
	    for(;i<N;i++) temp[i]=sequence[i];
	    int tick=0;
		for(int k=0;k<N;k++)
		if(tick++==0) cout<<temp[k];
		else cout<<" "<<temp[k];
		cout<<endl;
	}
	return 0; 
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章