Football Games HDU - 5873

A mysterious country will hold a football world championships—Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced.

At the first phase of the championships, teams are divided into MM groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.

When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups’ scores must be false.
Input
Multiple test cases, process till end of the input.

For each case, the first line contains a positive integers MM, which is the number of groups.
The ii-th of the next MM lines begins with a positive integer BiBi representing the number of teams in the ii-th group, followed by BiBi nonnegative integers representing the score of each team in this group.

number of test cases <= 10
M<= 100
Bii<= 20000
score of each team <= 20000
Output
For each test case, output MM lines. Output F" (without quotes) if the scores in the i-th group must be false, outputT” (without quotes) otherwise. See samples for detail.
Sample Input
2
3 0 5 1
2 1 1
Sample Output
F
T

思路:233一開始想太簡單了。。。本來足球是勝3平1負0啊 這裏 勝2這樣不管是什麼結果,只要隊伍數量定了那麼他們的得分總和就是定的。考慮前k個隊,這k個隊必定會每個隊之間都進行一次比賽,如果只考慮k個隊之間的關係,那麼得分應該是k*(k-1) 但是 還有多餘的隊伍,所以他們的得分必定是大於等於k (k-1)的 這樣我們把得分從小到大排序每次判斷一下,最後再判斷總和是不是n (n-1)

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<map>
using namespace std;

//thanks to pyf ...

#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define mp(x,y) make_pair(x,y)
typedef pair<int, int> PII;
typedef long long ll;

const int N = 1e6 + 5;

int a[N];
int main()
{
    int T;
    while (scanf("%d", &T) != EOF)
    {
        while (T--)
        {
            int n;
            scanf("%d", &n);
            for (int i = 1; i <= n; i++)
                scanf("%d", a + i);
            sort(a + 1, a + 1 + n);
            int sum = a[1];
            int flag = 1;
            for (int i = 2; i <= n; i++)
            {
                sum += a[i];
                if (sum < i * (i - 1))
                    flag = 0;
            }
            if (!flag || sum != n * (n - 1))
                printf("F\n");
            else
                printf("T\n");
        }
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章