HDU 4709 三循環暴力

Herding
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.
 

Input

The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case. 
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.
 

Output

For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.
 

Sample Input

1 4 -1.00 0.00 0.00 -3.00 2.00 0.00 2.00 2.00
 

Sample Output

2.00


這個題本身也確實比較簡單,題目說求最小面積,要面積最小的話,自然是三角形。所以問題就轉化在已知點中,求最小的三角形面積。

計算三角形面積,可以用海倫公式,也可以使用叉乘。我在這裏使用的是叉乘。

做題的過程中,我也是遇到了兩個問題。一個是在點的定義上用float的話會WA。所以還是使用double 來定義點。另外就是一定要判斷三個點是否能夠構成三角形。


下面是AC代碼:

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;

#define fn(i,n)  for(int i = 0; i < n; i++)

const double EPS = 1e-8;
const int INF = 0x3f3f3f3f;

struct piont
{
    double x, y;
} p[111];

double area(piont a,piont b,piont c)
{
    return fabs((b.x - a.x) * (c.y - a.y) - (c.x - a.x) * (b.y - a.y))/2.0;
}

int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        int n , sign = 1;
        double ans = INF;
        cin >> n;
        fn(i,n) cin >> p[i].x >> p[i].y;
               for(int i = 0; i < n - 2; i++)
            for(int j = i + 1; j < n - 1; j++)
                for(int k = j + 1; k < n; k++)
                {
                    double tmp;
                    tmp = area(p[i],p[j],p[k]);
                    if((tmp < ans)&&(tmp > EPS)) {
                            sign = 0;
                            ans = tmp;
                    }
                }
        if(sign)cout << "Impossible" << endl;
        else printf("%.2f\n", ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章