【hdu1023】Train Problem II(卡特蘭數模版題)

 

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12896    Accepted Submission(s): 6868


 
Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 
 
Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 
 
Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 
 
Sample Input

 
1 2 3 10
 
 
Sample Output

 
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
 
 
Author
Ignatius.L
 
 
Recommend
We have carefully selected several similar problems for you:  1133 1022 1130 1131 1134 

典型卡特蘭數模板題,大數打表 

公式:

 

import java.io.*;
import java.math.*;
import java.util.*;
 
public class Main {
	
	public static void main(String[] args){
		
		Scanner sc = new Scanner(System.in);
		
		BigInteger s[] = new BigInteger[105];
		
		s[1] = BigInteger.ONE;
		
		for(int i = 2;i < 105;i ++){
			
			s[i] = s[i-1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i + 1));
				
		}
		while(sc.hasNext()){
			
			int n =  sc.nextInt();
			System.out.println(s[n]);
		}
	}
}

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章