PAT 甲級 1076 Forwards on Weibo (30分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
1. 題目說的是: 一個粉絲只會在第一次遇到他關注的人發的微博的時候進行轉發,之後再遇到不會進行轉發

2. 輸出的結果是某條微博能夠被轉發的次數,其實就是一個層序遍歷
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;

vector<int> g[1100];
int vis[10010];
int n,l,num,id;

int query(int id){
    memset(vis,0,sizeof vis);
    queue<int> q;
    q.push(id);
    vis[id] = 1;
    int cnt = 0,level = 0;
    while(!q.empty()){
        int sz = q.size();
        level++;
        if (level > l) break;
        for (int i = 0; i < sz; ++i){
            int t = q.front();
            q.pop();
            for (auto x:g[t]){
                if (vis[x] == 0){
                    cnt++;
                    vis[x] ++;
                    q.push(x);
                }
            }
        }
    }
    return cnt;
}

int main(){

    cin>>n>>l;

    for (int i = 1; i <= n; ++i){
        cin >> num;
        for (int j = 0; j < num; ++j){
            cin >> id;
            g[id].push_back(i);
        }
    }

    cin >> n;
    for (int i = 0; i < n; ++i){
        cin >> id;
        cout<<query(id)<<endl;
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章