PAT 甲級 1035 Password (20分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified
這道題本身沒什麼難度,只不過有兩個小細節讓我找了好久。。。

1. 當n是1的時候,不論該不該密碼,都要輸出那就話: There...

2. 注意當n == 1 和 n > 1時輸出的話不僅是數字不同,單詞也不同,。。。

   There are N accounts and no account is modified

   There is 1 account and no account is modified

#include<iostream>
#include<vector>
using namespace std;

typedef pair<string,string> pss;

vector<pss> ans;
string names;
string passwords;

int main(){

    int n;
    cin>>n;
    for (int i = 0; i < n; ++i){
        cin>>names>>passwords;
        bool flag = 0;
        for (int j = 0; j < passwords.size(); ++j){
            if (passwords[j] == '1'){
                passwords[j] = '@';
                flag = 1;
            }
            else if (passwords[j] == '0'){
                passwords[j] = '%';
                flag = 1;
            }
            else if (passwords[j] == 'l'){
                passwords[j] = 'L';
                flag = 1;
            }
            else if (passwords[j] == 'O'){
                passwords[j] = 'o';
                flag = 1;
            }
        }
        if (flag) ans.push_back({names,passwords});
    }

    if(ans.size()){
        cout<<ans.size()<<endl;
        for (auto x:ans)    cout<<x.first<<" "<<x.second<<endl;
    }else if (n > 1) printf("There are %d accounts and no account is modified",n);

    if (n == 1)     cout<<"There is 1 account and no account is modified"<<endl;

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章