poj3080——Blue Jeans【KMP】

Blue Jeans

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21643   Accepted: 9609

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

South Central USA 2006

題目大意:給定m個字符串,問這m個字符串的最長公共子字符串是什麼。

大致思路:這道題給的數據比較小隻有60個,我們可以直接結合kmp暴力就可以了,我們可以先枚舉第一個字符串的所有的子字符串,然後在其他字符串中查找該字符串是否存在,然後不斷去最長長度。

#include <string>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 110;
int NextVal[MAXN];
string s[MAXN];

void GetNextVal(string a){
	NextVal[0] = -1;
	for(int i = 1,j = -1; i < a.size(); i++){
		while(j > -1 && a[i] != a[j + 1]) j = NextVal[j];
		if(a[i] == a[j + 1]) j++;
		NextVal[i] = j;
	}
}

bool KMP(string a,string b){
	for(int i = 0, j = -1; i < b.size(); i++){
		while(j > -1 && (j == a.size() - 1 || b[i] != a[j + 1])) j = NextVal[j];
		if(b[i] == a[j + 1]) j++;
		if(j == a.size() - 1){
			return true;
		}
	}
	return false;
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		for(int i = 0; i < n; i++) cin >> s[i];
		string ans = "";
		for(int i = 0; i < s[0].size(); i++){  //枚舉每一段截取的起點
			for(int j = 1; j <= s[0].size() - i; j++){  //枚舉長度
				string op = s[0].substr(i,j);
				GetNextVal(op);
				bool flag = true;
				for(int k = 1; k < n; k++){
					if(!KMP(op,s[k])){ flag = false; break; }
				}
				if(flag){
					if(ans.size() < op.size()) ans = op;
					else if(ans.size() == op.size()) ans = min(ans,op);
					else continue;
				}
			}
		}
		//cout << ans.size() << endl;
		if(ans.size() < 3) puts("no significant commonalities");
		else cout << ans << endl;
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章