poj 2182 Lost Cows(線段樹)

http://poj.org/problem?id=2182

Lost Cows

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14055   Accepted: 8944

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

USACO 2003 U S Open Orange


是個好題

樣例 1 2 1 0, 從後往前找,

0代表剩下的數中,沒有比他小的,那他就是1, 於是還剩 2 3 4 5

1代表剩下的數中,有一個比他小,就是3, 還剩 2 4 5

。。。。

最終序列就是2 4 5 3 1

利用線段樹存儲l 到 r中還有多少個數沒被去掉,每次面對一個ai 那麼就有ai個數比他小,那麼就找到ai+1的位置,就是對應的答案

 

#include<iostream>
using namespace std;

const int N = 8005;
struct node
{
	int l, r, sum;
}t[N<<2];
int a[N], ans[N];

void build(int x, int l, int r)
{
	t[x].l = l, t[x].r = r;
	t[x].sum = r - l + 1;
	
	if(l == r) return ;
	
	int mid = (l + r) >> 1;
	build(x<<1, l ,mid);
	build(x<<1|1, mid+1, r);
}

int update(int x, int k)
{
	t[x].sum--;
	
	if(t[x].l == t[x].r) return t[x].l;
	
	if(k <= t[x<<1].sum)//如果左子樹剩下的數夠 
		return update(x<<1, k);
	else
		return update(x<<1|1, k-t[x<<1].sum);//要減去左子樹剩下的數 
}

int main()
{
	int n;
	cin >> n;
	for(int i = 2; i <= n; i++)
	scanf("%d", a+i);
	
	build(1, 1, n);
	
	for(int i = n; i >= 1; i--)
	ans[i] = update(1, a[i]+1);
	
	for(int i = 1; i <= n; i++)
	cout << ans[i] << endl;
	
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章