STL 應用2 POJ 1007 DNA Sorting 題解 (STL完美解答)

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 63845   Accepted: 25209

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

本題屬於簡單題,只要讀懂題意就行了。 題意就是讓你做排序,這裏不多說了。想說的還是STL的兩個算法在這裏的應用:sort()和for_each()
sort()是STL排序算法,有兩個版本,分別是: sort(RandomAccessIterator  first, RandomAccessIterator  last),sort(RandomAccessIterator  first, RandomAccessIterator  last, Functor comp)。
for_each原型:for_each(InputIterator first, InputIterator last, Functor f)。
看看用STL寫的AC源碼:
#include <cstdio>
#include <algorithm>
using namespace std;
int n, len;
struct DNA
{
	char str[64];
	int val;
	DNA() : val(0) {}
	void evalue() {
		for (int i=len-1; i>=0; i--)
			for (int j=i; j>=0; j--)
				if ( str[j] > str[i] ) val++;
	}
}array[100];
bool comp(const DNA& a, const DNA& b) {	return a.val < b.val; }
void printdna(DNA& dna) {	puts(dna.str); }
int main()
{
	scanf("%d%d", &len, &n);
	for (int i=0; i<n; i++)
	{
		scanf("%s", array[i].str);
		array[i].evalue();
	}
	sort(array, array+n, comp);
	for_each(array, array+n, printdna);
return 0;	
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章