A1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

Solution: 

#include <bits/stdc++.h>
#define maxn 1005
using namespace std;
vector<int> adj[maxn];
int n, m, k, u, v, t;


int father[maxn];
bool vis[maxn];

void init() {
	for (int i = 1; i <= n; i++) {
		father[i] = i;
	}
}

int Find(int x) {
	int a = x;
	while (x != father[x]) {
		x = father[x];
	}
	while (a != father[a]) {
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}

void Union(int a, int b) {
	int fa = Find(a);
	int fb = Find(b);
	if (fa != fb) {
		father[fa] = fb;
	}
}

int main() {
	cin >> n >> m >> k;
	for (int i = 0; i < m; i++) {
		cin >> u >> v;
		adj[u].push_back(v);
		adj[v].push_back(u);
	}
	while(k--) {
		init();
		fill(vis, vis+maxn, false);
		cin >> t;
		for (int i = 1; i <= n; i++) {
			for (int j = 0; j < adj[i].size(); j++) {
				v = adj[i][j];
				if (i != t && v != t) {
					Union(i, v);
				}
			} 
		}
		int cnt = 0;
		for (int i = 1; i <= n; i++) {
			if (i == t) continue;
			int f = Find(i);
			if (!vis[f]) {
				cnt++;
				vis[f] = true;
			}
		}
		cout << cnt-1 << endl;
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章