A1028 List Sorting (25分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

Solution: 

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
typedef struct {
    int id;
    char name[9];
    int grade;
}Record;

int C;

bool Cmp(Record A, Record B) {
    if (C == 1) {
        return A.id < B.id;
    } else if (C == 2) {
        if (strcmp(A.name, B.name) != 0) {
            return strcmp(A.name, B.name) < 0;
        } {
            return A.id < B.id;
        }
    } else {
        if (A.grade != B.grade) {
            return A.grade < B.grade;
        } else {
            return A.id < B.id;
        }
    }
}

int main() {
    int N;
    cin >> N >> C;
    Record records[N];
    for (int i = 0; i < N; i++) {
        scanf("%d%s%d", &records[i].id, records[i].name, &records[i].grade);
    }
    sort(records, records + N, Cmp);
    for (int i = 0; i < N; i++) {
        printf("%06d %s %d\n", records[i].id, records[i].name, records[i].grade);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章