POJ2001 Shortest Prefixes

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
(就是對於一個單詞,輸出到其不具有公共部分的一位,如果整個單詞被其他詞包含,就完全輸出)

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Trie樹真是神奇呢


/**/
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int chnum=26;
struct NODE{
	int ct;//該節點被使用的次數
	short a[26];//子節點
}n[15000];
int cnt;//總節點數
char c[2000][25];
void ins(char s[]){
	int num=0,len=strlen(s);
	int i,j;
	for(i=0;i<len;i++)
	{
		if(n[num].a[s[i]-'a']==0){
			cnt++;//增加節點 
			n[num].a[s[i]-'a']=cnt;
			num=cnt;
		}
		else num=n[num].a[s[i]-'a'];//用已有結點
		
		n[num].ct++;//該節點使用次數+1
	}
	return;
}
void Print(char s[]){
	int num=0,len=strlen(s);
	printf("%s ",s);
	for(int i=0;i<len;i++){
		num=n[num].a[s[i]-'a'];
		printf("%c",s[i]);
		if(n[num].ct==1) {
		//printf("\n");//由於有些詞是被完全包含在其他詞裏的,故不能在這裏換行
		break;}
	}
	printf("\n");
	return;
}
int main(){
	int i=0,j;
	while(cin>>c[i] && c[i]!='\0')ins(c[i++]);
	for(j=0;j<i;j++)Print(c[j]);
	return 0;
}







發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章