Z - Simpsons’ Hidden Talents(擴展KMP 模板題)

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. 
Marge: Yeah, what is it? 
Homer: Take me for example. I want to find out if I have a talent in politics, OK? 
Marge: OK. 
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix 
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton 
Marge: Why on earth choose the longest prefix that is a suffix??? 
Homer: Well, our talents are deeply hidden within ourselves, Marge. 
Marge: So how close are you? 
Homer: 0! 
Marge: I’m not surprised. 
Homer: But you know, you must have some real math talent hidden deep in you. 
Marge: How come? 
Homer: Riemann and Marjorie gives 3!!! 
Marge: Who the heck is Riemann? 
Homer: Never mind. 
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. 
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

題目大意:

找出a的前綴和b的後綴的公共最大長度,並輸出

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
using namespace std;
typedef long long ll;
//#define int ll
typedef long double ld;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define mem(a, b) memset(a, b, sizeof(a))
const double pi = acos(-1.0);
const double eps = 1e-6;
const ll mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const ll INF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 1e5 + 5;
char s1[maxn];
char s2[maxn];
int Next[maxn];
int len1, len2;
int extend[maxn];
void get_next()
{
    int a = 0;
    int p = 0;
    Next[0] = len2;
    for(int i=1; i<len2; i++)
    {
        if(i >= p || i + Next[i - a] >= p)
        {
            if(i >= p) p = i;
            while(p < len2 && s2[p] == s2[p - i]) p++;
            Next[i] = p - i;
            a = i;
        }
        else Next[i] = Next[i - a];
    }
}
void exkmp()
{
    get_next();
    int a = 0;
    int p = 0;
    for(int i=0; i<len1; i++)
    {
        if(i >= p || i + Next[i - a] >= p)
        {
            if(i >= p) p = i;
            while(p < len1 && p - i < len2 && s1[p] == s2[p - i]) p++;
            extend[i] = p - i;
            a = i;
        }
        else extend[i] = Next[i - a];
    }
}
int main()
{
    ios;
    while(cin >> s2 >> s1)
    {
        len1 = strlen(s1);
        len2 = strlen(s2);
        exkmp();
        int ans = 0;
        for(int i=len1 - 1, j = 0; j < len2 ;j++, i--)
        {
            if(extend[i] == len1 - i)
            {
                ans = max(ans, extend[i]);
            }
        }
        if(ans != 0)
        {
            for(int i=0; i<ans; i++)
            {
                cout << s2[i];
            }
            cout << ' ';
        }
        cout << ans << endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章