zoj2388----------------Beat the Spread!

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?


Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.


Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.


Sample Input

2
40 20
20 40


Sample Output

30 10
impossible



考慮三種情況是IMPOSSIBLE

1、和比差還小

2、和與差的和不能被2 整除

3、和與差的差不能被2整除



代碼:



#include <iostream>
#include <cmath>
using namespace std;

int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int s,d;
		cin>>s>>d;
		int x=(s+d)/2;
		double y=abs(double((s-d)/2));
		if(s-d<0||(s+d)%2!=0||(s-d)%2!=0)
			cout<<"impossible"<<endl;
		else
			cout<<x<<" "<<y<<endl;		
	}
	return 0;	
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章