hdu 3449 Consumer 條件揹包 有錢w,給出n種選擇,每種選擇有m[i]個物品,但必須先買盒子,價格p[i],求買的物品的最大價值

Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.
 


 

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)
 


 

Output
For each test case, output the maximum value FJ can get
 


 

Sample Input
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60
 


 

Sample Output
210

 

 //

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=110000;
int boxn,money;//箱子數量,總錢數
int dp[maxn],f[maxn];//加上當前最大價值,前i行最大價值
int boxv[60];//箱子花費
int num[60];//箱子帶物品個數
int c[60][20],v[60][20];//物品花費,價值
int main()
{
    while(scanf("%d%d",&boxn,&money)==2)
    {
        for(int i=1;i<=boxn;i++)
        {
            scanf("%d%d",&boxv[i],&num[i]);
            for(int j=1;j<=num[i];j++) scanf("%d%d",&c[i][j],&v[i][j]);
        }
        memset(f,0,sizeof(f));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=boxn;i++)
        {
            for(int j=boxv[i];j<=money;j++) dp[j]=f[j-boxv[i]];//加上當前箱子的花費
            for(int j=1;j<=num[i];j++)
            {
                for(int k=money;k>=c[i][j]+boxv[i];k--)
                {
                    dp[k]=max(dp[k],dp[k-c[i][j]]+v[i][j]);
                }
            }
            for(int j=boxv[i];j<=money;j++) f[j]=max(f[j],dp[j]);
        }
        printf("%d\n",f[money]);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章