HDU 1114 || POJ 1384 Piggy-Bank

Piggy-Bank
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8288   Accepted: 4016

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.

This is impossible.


題目大意:

 

給你一隻可以存錢的小豬,告訴你空豬的重量和裝了硬幣的小豬重量。並給你各種金額的硬幣的重量,讓你求這隻豬最少裝了多少錢。

 

大致思路:

 

這道題很明顯是完全揹包類的題目,而且是很簡單的那種,只要對於完全揹包的狀態轉移方程比較熟悉的話都不難寫出來。

 

唯一讓我覺得比較卡的點是初始化問題。因爲要求的是最小值,所以全部初始化爲無窮大,唯一例外就是dp[0]必須初始化爲0

 

普通的完全揹包一般求的是最大值,如果還要求必須“恰好裝滿”的話,除了第一行第一列初始化爲0外,其他一律初始化爲負無窮,對於用一維數組來做的話,就是dp[0]=0,其他初始化爲負無窮。

 

哇靠,寫到這裏突然明白了爲什麼初始化是那樣子的。果然寫博客有助於理解題意,good job

 

接下來放出代碼:

//poj1384.cpp -- Piggy-Bank
//初始化部分還不是很理解。
//現在理解了,啦啦啦~~~
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <iomanip>
typedef long long ll;
using namespace std;
const int maxn = 500 + 10;
const int maxm = 10000 + 10;
const int INF = 10000000;
int E, F, N, W;
int p[maxn], w[maxn];
int dp[maxm+1];
void solve()
{
	for(int i=0; i<=W; i++ )
		dp[i] = INF;
	dp[0] = 0;
	for( int i=1; i<=N; i++ )
	{
		for( int j=w[i]; j<=W; j++ )
		{
			dp[j] = min(dp[j], dp[j-w[i]]+p[i]);
		}
	}
	if( dp[W]!=INF )
		printf("The minimum amount of money in the piggy-bank is %d.\n", dp[W]);
	else
		printf("This is impossible.\n");
}
int main(void)
{
	int t;
	cin>>t;
	while( t-- )
	{
		cin>>E>>F>>N;
		W = F - E;
		for( int i=1; i<=N; i++ )
			scanf("%d %d", &p[i], &w[i]);
		solve();
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章