HDUACM2028

Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47977    Accepted Submission(s): 19890


Problem Description
求n個數的最小公倍數。
 

Input
輸入包含多個測試實例,每個測試實例的開始是一個正整數n,然後是n個正整數。
 

Output
爲每組測試數據輸出它們的最小公倍數,每個測試實例的輸出佔一行。你可以假設最後的輸出是一個32位的整數。
 

Sample Input
2 4 6 3 2 5 7
 

Sample Output
12 70
 

Author
lcy
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2032 2031 2029 2030 2024 


#include<stdio.h>
#include<String.h>
long   divisor(long a,long b){
	if(a%b==0){
		return b;
	}else{
		return divisor(b,a%b);
	}	
}
int main(){
	int n;
	long a,b;     //注意需要用長整形   否則a*b會越界
	while(scanf("%d",&n) !=EOF&&n>0){
		
		scanf("%d",&a);
		if(n==1) {printf("%d\n",a);continue;}
		for(int i =1;i<n;i++){
			scanf("%d",&b);
			a = a*b/divisor(a,b);
		}
		
		printf("%d\n",a);
		
	}
	
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章