hdu3410 單調隊列

**

Passing the Message

**

Problem Description

What a sunny day! Let’s go picnic and have barbecue! Today, all kids
in “Sun Flower” kindergarten are prepared to have an excursion. Before
kicking off, teacher Liu tells them to stand in a row. Teacher Liu has
an important message to announce, but she doesn’t want to tell them
directly. She just wants the message to spread among the kids by one
telling another. As you know, kids may not retell the message exactly
the same as what they was told, so teacher Liu wants to see how many
versions of message will come out at last. With the result, she can
evaluate the communication skills of those kids. Because all kids have
different height, Teacher Liu set some message passing rules as below:

1.She tells the message to the tallest kid.

2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.

3.A kid’s “left messenger” is the kid’s tallest “left follower”.

4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than
one “left follower”.

5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.

The definition of “right messenger” is similar to the definition of
“left messenger” except all words “left” should be replaced by words
“right”.

For example, suppose the height of all kids in the row is 4, 1, 6, 3,
5, 2 (in left to right order). In this situation , teacher Liu tells
the message to the 3rd kid, then the 3rd kid passes the message to the
1st kid who is his “left messenger” and the 5th kid who is his “right
messenger”, and then the 1st kid tells the 2nd kid as well as the 5th
kid tells the 4th kid and the 6th kid. Your task is just to figure out
the message passing route.

Input

The first line contains an integer T indicating the number of test
cases, and then T test cases follows. Each test case consists of two
lines. The first line is an integer N (0< N <= 50000) which represents
the number of kids. The second line lists the height of all kids, in
left to right order. It is guaranteed that every kid’s height is
unique and less than 2^31 – 1 .

Output

For each test case, print “Case t:” at first ( t is the case No.
starting from 1 ). Then print N lines. The ith line contains two
integers which indicate the position of the ith (i starts form 1 )
kid’s “left messenger” and “right messenger”. If a kid has no “left
messenger” or “right messenger”, print ‘0’ instead. (The position of
the leftmost kid is 1, and the position of the rightmost kid is N)

Sample Input

2
5
5 2 4 3 1
5
2 1 4 3 5

Sample Output

Case 1:
0 3
0 0
2 4
0 5
0 0
Case 2:
0 2
0 0
1 4
0 0
3 0

思路:
題意就是求一個數,左邊比他小的數中的最大值,右邊比他小的數中的最大值。
用單調隊列來維護,維護一個單調遞減的隊列。
隊列爲空,直接進隊列。
隊列非空時,一個數和隊尾元素比較,如何比他大就進,就講隊尾元素彈出,並更新隊尾元素左邊的最大值。同時更新這個數左邊的最大值。

代碼:

#include<cstdio>
const int N=500005;
int que[N];
int tall[N];
struct node{
    int l,r;
}st[N];
int main()
{
    int T;
    scanf("%d",&T);
    for(int ca=1;ca<=T;ca++)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",&tall[i]);
        int head=1,tail=1;
        for(int i=1;i<=n;i++){
            int t=0;
            while(head<tail&&tall[que[tail-1]]<tall[i]){
                tail--;
                st[que[tail]].r=t;
                t=que[tail];    
            }//隊尾元素出隊列,並更新其右邊元素最大值
            st[i].l=t;//進隊列,更新其左邊元素最大值
            que[tail++]=i;
        }
        while(head+1<tail){
            st[que[head]].r=que[head+1];
            head++;
        }
        st[que[head]].r=0;
        printf("Case %d:\n",ca);
        for(int i=1;i<=n;i++)
            printf("%d %d\n",st[i].l,st[i].r);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章