POJ-2002 Squares 解題報告

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1


       題目鏈接:http://poj.org/problem?id=2002

       解法類型:二分 || hash

       解題思路:這題目我是用二分做的,即枚舉兩個點作爲一條邊,然後根據三角形全等求出正方形的另外兩個點,再二分查找是否存在該點就可以了。但這題目用hash的效率更高一點,建立散列hash表,直接查找就可以了。

       算法實現:

//STATUS:C++_AC_1313MS_172K
#include<stdio.h>
#include<stdlib.h>
const int MAXN=1010;
int cmp_num(const void *a,const void *b);
void judge(int x1,int y1,int x2,int y2);
int map[MAXN][2],tot,n;
int main()
{
//	freopen("in.txt","r",stdin);
	int i,j;
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
			scanf("%d%d",&map[i][0],&map[i][1]);

		qsort(map,n,sizeof(int)*2,cmp_num);   //對座標點進行快速排序

		tot=0;
		for(i=0;i<n-1;i++)
			for(j=i+1;j<n;j++){         //依次枚舉所有點,然後進行判斷
				judge(map[i][0],map[i][1],map[j][0],map[j][1]);
			}
		
		printf("%d\n",tot/2);
	}
	return 0;
}
void judge(int x1,int y1,int x2,int y2)
{
	int t,i,x3,y3,x4,y4,ok,low,mid,high;
	if(y1>y2)t=x1,x1=x2,x2=t,t=y1,y1=y2,y2=t;  //這裏一定要注意正方形的方向性
	x3=x1+(y1-y2);y3=y1-(x1-x2);     //全等三角形求出點
    x4=x2+(y1-y2);y4=y2-(x1-x2);
	ok=0,low=0,high=n;	
	while(low<high){     //二分查找第一個點
		mid=(low+high)/2;
		if(map[mid][0]>=x3)high=mid;
		else low=mid+1;
	}
	for(i=low;map[i][0]==x3;i++)   //判斷第一個點
		if(map[i][1]==y3){ok=1;break;}

	if(ok){        //判斷第二個點
		ok=0,low=0,high=n;
		while(low<high){
	    	mid=(low+high)/2;
			if(map[mid][0]>=x4)high=mid;
			else low=mid+1;
		}
		for(i=low;map[i][0]==x4;i++)
			if(map[i][1]==y4){ok=1;break;}
	}
	if(ok){       //總數加一
		tot++;
	}
}

int cmp_num(const void *a,const void *b)
{
	return *(int*)a - *(int*)b;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章