hdu1004 -Let the Balloon Rise

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red

pink

題意:給出n個字符串,輸出出現次數最多的字符串

#include <iostream>
#include <cstring>
#include<string>
using namespace std;
int main()
{
    int n,i,j;
    int a[1001];
    string s[1001];
    while(cin>>n&&n)
    {
        int maxn=-1;
        for(i=0; i<n; i++)
        {
            a[i]=0;
            cin>>s[i];
            for(j=0; j <i; j++)
                if(s[i]==s[j])
                    a[i]++;
        }
        int num=0;
        for(i=0; i<n; i++)
            if(maxn<a[i])
            {
                maxn=a[i];
                num=i;
            }
        cout<<s[num]<<endl;
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章