【主席樹】POJ 2014 K-th Number

POJ 2014 K-th Number


Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.


Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).


Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.


Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3


Sample Output

5
6
3


HINT

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.


Solution

題意就是給你一個數組然後求其中一段區間的第k大
離散一下吧。。
然後貌似可以分塊?(並不行)
這裏介紹另外一種算法

主席樹:
一種神奇的方法
首先每個節點建一棵樹,每個點權值是前k個元素在該點管轄範圍[L,R]之間的元素個數(也可以說前綴和)
然而這樣建樹是n^2logn的空間?
我們發現,每次加一個元素,只會修改樹的左子樹或者右子樹.
所以每次使用一下之前的樹即可,空間優化到nlogn.
詢問[l,r]區間第k大時二分一下即可.

Code

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;

#define maxn 100001

struct node{
    int l,r,v;
}t[maxn*20];

inline int in()
{
    int x=0,f=1;char ch=getchar();
    while((ch<'0'||ch>'9')&&ch!='-')ch=getchar();
    if(ch=='-')ch=getchar(),f=-1;
    while(ch<='9'&&ch>='0')x=x*10+ch-'0',ch=getchar();
    return x*f;
}

int a[maxn],p[maxn],b[maxn],size,root[maxn];

bool cmp(const int A,const int B){return a[A]<a[B];}

void update(int &poi,int l,int r,int num)
{
    t[++size]=t[poi];poi=size;
    t[size].v++;
    if(l==r)return;
    int mid=(l+r)>>1;
    if(num>mid)update(t[poi].r,mid+1,r,num);
    else update(t[poi].l,l,mid,num);
}

int query(int L,int R,int l,int r,int k)
{
    if(l==r)return l;
    int T=t[t[R].l].v-t[t[L].l].v;
    int mid=(l+r)>>1;
    if(T>=k)return query(t[L].l,t[R].l,l,mid,k);
    else return query(t[L].r,t[R].r,mid+1,r,k-T);
}

int main()
{
    freopen("2104.in","r",stdin);
    int n,m,x,y,k;
    n=in(),m=in();
    for(int i=1;i<=n;i++)a[i]=in(),p[i]=i;
    sort(1+p,p+n+1,cmp);
    for(int i=1;i<=n;i++)b[p[i]]=i;
    for(int i=1;i<=n;i++)
    {
        root[i]=root[i-1];
        update(root[i],1,n,b[i]);
    }
    for(int i=1;i<=m;i++)
    {
        x=in(),y=in(),k=in();
        int X=query(root[x-1],root[y],1,n,k);
        printf("%d\n",a[p[X]]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章