2017杭電多校聯賽-Function

Function

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1594    Accepted Submission(s): 302


Problem Description
You are given a permutation a from 0 to n1 and a permutation b from 0 to m1.

Define that the domain of function f is the set of integers from 0 to n1, and the range of it is the set of integers from 0 to m1.

Please calculate the quantity of different functions f satisfying that f(i)=bf(ai) for each i from 0 to n1.

Two functions are different if and only if there exists at least one integer from 0 to n1 mapped into different integers in these two functions.

The answer may be too large, so please output it in modulo 109+7.
 

Input
The input contains multiple test cases.

For each case:

The first line contains two numbers n, m(1n100000,1m100000)

The second line contains n numbers, ranged from 0 to n1, the i-th number of which represents ai1.

The third line contains m numbers, ranged from 0 to m1, the i-th number of which represents bi1.

It is guaranteed that n106, m106.
 

Output
For each test case, output "Case #xy" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input
3 2 1 0 2 0 1 3 4 2 0 1 0 2 3 1
 

Sample Output
Case #1: 4 Case #2: 4
題目大意:給你一些個關係式f(i)=bf(a(i)),詢問滿足這個關係式有多少種可能。
解題思路:
其實這道題可以轉化爲求環的問題,有多少種方式可以構成題目要求的環,即b的環可以有多少種方式畫成a的環
來看第一個樣例:
a:1 , 0 , 2
b:0 , 1
則a0->a1->a0, a2->a2
b0->b0, b1->b0
則,由圖可以得到a的第一環可以由b的兩種方式構成,a的第二個環可以由b的兩種方式構成,則由b構成a總共有2*2=4種方式。
讓我們看第二個樣例:
a:2 , 0 , 1
b: 0 , 2 , 3 , 1
則a:a0->a2->a1->a0
b: b0->b0 b1->b2->b3->b1
即:
如圖,a只有一種環,所以b只需要構成這一種環就行了,有4種方式可以構成這個環。
所以題目轉換爲求構成環的方式了。
ac代碼:
#include <bits/stdc++.h>
using namespace std;
#define ll long long
#define pb push_back
#define mkp make_pair
#define ite iterator
#define fi first
#define se second
#define FOR(i, l, r) for(int i = l; i <= r; i++)
#define ROF(i, r, l) for(int i = r; i >= l; i--)
#define M 1000000007

const int maxn = 100100;
int n, m, cal[2][maxn], a[maxn], b[maxn], ans = 1;
bool vis[maxn];

void dfs(int t, int l, int *a, int k){
	if(vis[t]){
		cal[k][l]++;
		return;
	}
	vis[t] = 1;
	dfs(a[t], l + 1, a, k);
}

int main(){
    int ca = 0;
	while(~scanf("%d%d", &n, &m)){
		for(int i = 0; i < n; i++)
			scanf("%d", a + i);
		for(int i = 0; i < m; i++)
			scanf("%d", b + i);
		memset(cal, 0, sizeof(cal));
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < m; i++)
			if (!vis[i]) dfs(i, 0, b, 0);
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < n; i++)
			if (!vis[i]) dfs(i, 0, a, 1);
		ans = 1;
		for(int i = 1; i <= n; i++)
			if(cal[1][i]){
				int lim = (int)sqrt(i + 0.5), ta = 0;
				for(int j = 1; j <= lim; j++)
					if(i % j == 0){
						(ta += (ll)cal[0][j] % M * j % M) %= M;
						if (j * j != i) (ta += (ll)cal[0][i / j] % M * (i / j) % M) %= M;
					}
				for(int j = 1; j <= cal[1][i]; j++)
					ans = (ll)ans * ta % M;
			}
		printf("Case #%d: %d\n", ++ca, ans);
	}
  return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章