NYOJ 30 - Gone Fishing

描述

 John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

输入

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.
输出For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.


样例输入

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0


 样例输出

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724 


 题意:John要钓鱼,有 n 个鱼塘,John有 t 小时的时间,每个鱼塘中有 F[i] 条鱼,每次钓鱼这个鱼塘就会减少 D[i] 条鱼,从鱼塘 i-1 到 i 需要花费 T[i] 分钟,求出怎么能够得到最多的鱼数,并求出在每个鱼塘花费的时间。每次钓鱼花费5分钟,且给出的时间一定是5分钟的倍数。

是一道贪心题目,因为每次鱼的减少情况只与在这个鱼塘的钓鱼次数有关,所以是贪心。我们枚举前 i 个鱼塘能够得到的最大鱼数,并且计算每个鱼塘花费的时间,选出最大数量作为答案。

我使用了优先队列,这样排序比较方便。

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;

struct node
{
    int no, fish, down, time;
    friend bool operator < (const node &a, const node &b)
    {
        if (a.fish != b.fish)
            return a.fish < b.fish;
        return a.no > b.no;

    }
};
node pool[30];

priority_queue<node> Q;
int h, n, maxsum;
int ans[30], time[30];

void greedy()
{
    maxsum = -1;
    for (int i = 0; i < n; ++i)
    {
        while (!Q.empty())
            Q.pop();
        for (int j = 0; j <= i; ++j)
            Q.push(pool[j]);

        int leave = h - pool[i].time;
        int sum = 0;
        memset(time, 0, sizeof(time));

        while (leave > 0)
        {
            node tmp = Q.top();
            Q.pop();
            if (tmp.fish <= 0)
                break;

            sum += tmp.fish;
            tmp.fish -= tmp.down;
            time[tmp.no] += 5;
            Q.push(tmp);
            leave -= 5;
        }
        if (leave > 0)
            time[0] += leave;
        if (sum > maxsum)
        {
            maxsum = sum;
            for (int j = 0; j < n; ++j)
                ans[j] = time[j];
        }
    }
}

int main()
{
    while (scanf("%d", &n) != EOF && n != 0)
    {
        scanf("%d", &h);
        h *= 60;
        for (int i = 0; i < n; ++i)
        {
            scanf("%d", &pool[i].fish);
            pool[i].no = i;
        }
        for (int i = 0; i < n; ++i)
            scanf("%d", &pool[i].down);
        pool[0].time = 0;
        for (int i = 1; i < n; ++i)
        {
            int t;
            scanf("%d", &t);
            pool[i].time = pool[i-1].time + 5*t;
        }

        greedy();

        for (int i = 0; i < n; ++i)
        {
            printf("%d", ans[i]);
            if (i < n-1)
                printf(", ");
        }
        printf("\n");
        printf("Number of fish expected: %d\n", maxsum);
    }
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章