数据结构实验之链表一:顺序建立链表 (sdut oj)


数据结构实验之链表一:顺序建立链表

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。


Input

第一行输入整数的个数N;
第二行依次输入每个整数。


Output

输出这组整数。


Example Input

8
12 56 4 6 55 15 33 62


Example Output

12 56 4 6 55 15 33 62


Hint

不得使用数组!

Author








参考代码


#include<stdio.h>
#include<stdlib.h>

struct node
{
    int data;
    struct node *next;
};

int main()
{
    int n;
    struct node *head,*p,*tail;
    scanf("%d",&n);
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    while(n--)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = tail->next;
        tail->next = p;
        tail = p;
    }
    p = head->next;
    printf("%d",p->data);
    p = p->next;
    while(p)
    {
        printf(" %d",p->data);
        p = p->next;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章