【計算幾何】POJ 1113

題目鏈接:
http://poj.org/problem?id=1113

原題:

Wall

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31393 Accepted: 10609

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King’s castle. The King was so greedy, that he would not listen to his Architect’s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King’s requirements.

The task is somewhat simplified by the fact, that the King’s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle’s vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King’s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle’s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King’s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output
1628

Hint

結果四捨五入就可以了

Source

Northeastern Europe 2001


題目大意:
給定一個點集,求一個圖形使它的每個點到點集中任意一點的距離都大於等於L。

很容易發現,我們需要求得就是這個點集的凸包的周長加上一個以L爲半徑的圓的周長之和就可以了。

附上AC代碼:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

const double Pi = 3.1415926;

class Point
{
    public:
        double x, y;
    public:
        Point(double x = 0, double y = 0) : x(x), y(y) {}
};

typedef Point Vector;

Vector operator + (const Vector &a, const Vector &b)
{
    return Vector(a.x+b.x, a.y+b.y);
}

Vector operator - (const Vector &a, const Vector &b)
{
    return Vector(a.x-b.x, a.y-b.y);
}

Vector operator * (const Vector &a, const double &b)
{
    return Vector(a.x*b, a.y*b);
}

Vector operator / (const Vector &a, const double &b)
{
    return Vector(a.x/b, a.y/b);
}

double Dot(const Vector &a, const Vector &b)
{
    return a.x*b.x + a.y*b.y;
}

double Cross(const Vector &a, const Vector &b)
{
    return a.x*b.y - a.y*b.x;
}

double Length(const Vector &a)
{
    return sqrt(Dot(a, a));
}

bool operator < (const Point &a, const Point &b)
{
    return a.x < b.x || (a.x == b.x && a.y < b.y);
}

int convexhull(Point *p, int n, Point *ch)
{
    sort(p, p+n);
    int m = 0;
    for (int i = 0; i < n; i++) {
        while (m > 1 && Cross(ch[m-1]-ch[m-2], p[i]-ch[m-2]) <= 0)
            m--;
        ch[m++] = p[i];
    }
    int k = m;
    for (int i = n-1; i >= 0; i--) {
        while (m > k && Cross(ch[m-1]-ch[m-2], p[i]-ch[m-2]) <= 0)
            m--;
        ch[m++] = p[i];
    }
    if (n > 1)
        m--;
    return m;
}

double ConvexLength(Point *p, int n)
{
    double length = 0;
    for (int i = 1; i < n; i++)
        length += Length(p[i]-p[i-1]);
    length += Length(p[0]-p[n-1]);
    return length;
}

Point p[1500];
Point c[1500];

int main()
{
    int n;
    double l;
    scanf("%d %lf", &n, &l);
    for (int i = 0; i < n; i++)
        scanf("%lf %lf", &p[i].x, &p[i].y);
    int m = convexhull(p, n, c);
    double ans = ConvexLength(c, m)+2*Pi*l;
    printf("%.lf\n", ans);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章