sgu 115. Calendar 水

115. Calendar

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

First year of new millenium is gone away. In commemoration of it write a program that finds the name of the day of the week for any date in 2001.

Input

Input is a line with two positive integer numbers N and M, where N is a day number in month MN and M is not more than 100.

Output

Write current number of the day of the week for given date (Monday – number 1, … , Sunday – number 7) or phrase “Impossible” if such date does not exist.

Sample Input

21 10

Sample Output

7


#include <bits/stdc++.h>

using namespace std;
int mm[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};

void solve(){
    int n,m;
    scanf("%d %d",&n,&m);
    if(m>12){
        printf("Impossible");
        return;
    }

    if(n>mm[m]){
        printf("Impossible");
        return;
    }

    int day=n;
    for(int i=1;i<m;i++){
        day+=mm[i];
    }
    printf("%d",(day-1)%7+1);

}

int main(){
    solve();
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章