sgu 133. Border 貪心

133. Border

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

Along the border between states A and B there are N defence outposts. For every outpost k, the interval [Ak,Bk] which is guarded by it is known. Because of financial reasons, the president of country A decided that some of the outposts should be abandoned. In fact, all the redundant outposts will be abandoned. An outpost i is redundant if there exists some outpost j such that Aj<Ai and Bi<Bj. Your task is to find the number of redundant outposts.

Input

The first line of the input will contain the integer number N (1<=N<=16 000). N lines will follow, each of them containing 2 integers: Ak and Bk (0<= Ak < Bk <= 2 000 000 000), separated by blanks. All the numbers Awill be different. All the numbers Bk will be different.

Output

You should print the number of redundant outposts.

Sample Input

5
0 10
2 9
3 8
1 15
6 11

Sample Output

3

刪除多餘區間


#include <bits/stdc++.h>

using namespace std;

struct node{
    int a;
    int b;
};

node no[16005];

bool cmp(node x,node y){
    if(x.a==y.a){
        return x.b>y.b;
    }
    return x.a<y.a;
}

void solve(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d%d",&no[i].a,&no[i].b);
    }
    sort(no,no+n,cmp);

//    for(int i=0;i<n;i++){
//        cout<<no[i].a<<" "<<no[i].b<<endl;
//    }
    int ans=0;
    int maxx=no[0].b;
    for(int i=1;i<n;i++){
        if(no[i].b>maxx){
            maxx=no[i].b;
        }
        else{
            ans++;
        }
    }
    printf("%d",ans);


}

int main(){
    solve();
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章