hdu 1157 (1.3.7) Who's in the Middle

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">* Line 1: A single integer that is the median milk output.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="FONT-FAMILY: Courier New,Courier,monospace">5
2
4
1
3
5</div>
 

Sample Output
3
題目實際上是排序,但是用c的輸入輸出貌似就過不去啊,cin和cout纔可以
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.


// 解法1:使用qsort快排 
//#include <iostream>
//#include <stdlib.h>
//using namespace std;
//int cmp(const void *a, const void *b)
//{
//	return (*(int*)a - *(int*)b);
//}
//
//int main(void)
//{
//	int n, i;
//    int number[100000] = {0};	
//	while(cin >> n)
//	{
//		for(i = 0; i < n; i++)
//			cin >> number[i];
//		qsort(number, n, sizeof(int), cmp);
//		cout << number[(n-1)/2] << endl;
//	}
//	
//	return 0;
//}
// 解法2:使用sort排序 
#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(int a, int b)
{
	return a > b;
}
int main(void)
{
	int n, i;
	int num[10000];
	while(cin >> n)
	{
		for(i = 0; i < n; i++)
			cin >> num[i];
		sort(num, num + n, cmp);
		cout << num[(n-1)/2] << endl; 
	}
	
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章