poj 1654 Area(神題)

題目銜接:http://poj.org/problem?id=1654

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22770   Accepted: 6146

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

Source

 題目大意:給你一個字符串,串表示的是對於這個點的操作,如何操作自行看題,然後保證這些點能組成一個四邊形,問你最後這個四邊形的面積是多少

思路:題意如此簡單,坑點卻是一個比一個多,果然計算幾何的題能1A的題都基本不存在,這個題要注意的有:

1.內存問題:如果要存點,必須用整數不能用double存否則會爆內存

2.注意要用long long 不能用double這個是不行的,

3.如果是存點最後計算面積,我們可能馬上想到的是叉積計算,如果這樣算我們不能提前取絕對值,不然會wa到吐(例如樣例:862688444226 正確答案是5

4.由於答案最後既有整數也有小數,所以我們在計算的時候要用整數存,不能用double或者float,最後還需要判斷能否整除

坑點大概就這麼些

代碼: 

/*
題目大意:給你一個字符串,代表走的方向,從原點開始走,問你最後的面積是多少,5代表結束前進
題目保證這個圖形是能夠合併的

思路:按照他所給的方式走下去,直接得出答案
*/
#include<set>
#include<map>
#include<ctime>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f
#define bug  printf("bug\n")
const int maxn=1e6+10;
const double pi=acos(-1.0);
const double esp=1e-6;
const int N=2e2+10;
struct point
{
    int x,y;
};
point p[maxn];
int cmult(point a,point b,point c)///叉積
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
char s[maxn];
int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%s",s);
        int l=strlen(s);
        int cnt=1;
        p[0].x=0,p[0].y=0;
        for(int i=0;i<l;i++)
        {
            if(s[i]=='5')
                break;
            else
            {
                if(s[i]=='8')
                {
                    p[cnt].x=p[cnt-1].x;
                    p[cnt].y=p[cnt-1].y+1;
                }
                else if(s[i]=='2')
                {
                    p[cnt].x=p[cnt-1].x;
                    p[cnt].y=p[cnt-1].y-1;
                }
               else if(s[i]=='6')
                {
                    p[cnt].x=p[cnt-1].x+1;
                    p[cnt].y=p[cnt-1].y;
                }
                else if(s[i]=='4')
                {
                    p[cnt].x=p[cnt-1].x-1;
                    p[cnt].y=p[cnt-1].y;
                }
                else if(s[i]=='9')
                {
                    p[cnt].x=p[cnt-1].x+1;
                    p[cnt].y=p[cnt-1].y+1;
                }
                else if(s[i]=='7')
                {
                    p[cnt].x=p[cnt-1].x-1;
                    p[cnt].y=p[cnt-1].y+1;
                }
                else if(s[i]=='3')
                {
                    p[cnt].x=p[cnt-1].x+1;
                    p[cnt].y=p[cnt-1].y-1;
                }
                else if(s[i]=='1')
                {
                    p[cnt].x=p[cnt-1].x-1;
                    p[cnt].y=p[cnt-1].y-1;
                }
                cnt++;
            }
        }
        ll ans=0;
        for(int i=1;i<cnt-2;i++)
        {
            ans+=(cmult(p[0],p[i],p[i+1]));
        }
        ll ss=(ll)fabs(ans);
        if(ss%2==0)
            printf("%lld\n",ss/2);
        else
            printf("%lld.5\n",ss/2);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章