poj-2007 Description

題目銜接:http://poj.org/problem?id=2007

Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly once, one comes back to the starting vertex. 

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have any "dents".) 


The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0). 

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with (0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 

 

Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999. The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip taken along the polygon's border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

Sample Input

0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10

Sample Output

(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)

題目大意:說實話我也不知道這個題是啥,感覺像是極角排序輸出,試了一發,竟然A了,A了。。。。吐槽一下這個輸入方式,很無語。。。

思路:極角排序輸出

代碼1:凸包的基礎上改的,,,


/*
題目大意:

思路:
*/
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<cstdio>
#include <vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll unsigned long long
#define inf 0x3f3f3f
#define esp 1e-8
#define bug {printf("mmp\n");}
#define mm(a,b) memset(a,b,sizeof(a))
#define T() int test,q=1;scanf("%d",&test); while(test--)
#define Test() {freopen("F:\\test.in","r",stdin);freopen("F:\\test1.out","w",stdout);}
const int maxn=2e4+10;
const double pi=acos(-1.0);
const int N=110;
const ll mod=1e9+7;
struct point
{
    int x,y;
} p[maxn];
int Stack[maxn],top;

double dis(point a,point b)
{
    return sqrt((double)pow(a.x-b.x,2)+(double)pow(a.y-b.y,2));
}
int mulit(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}

bool cmp(point a,point b)
{
    int x=mulit(p[0],a,b);
    if(x>0)
        return true;
    else if(x==0&&dis(a,p[0])<dis(b,p[0]))
        return true;
    return false;
}

void tb(int n)
{
    point p0;
    int k=0;
    p0=p[0];
    for(int i=1; i<n; i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x>p[i].x))
        {
            p0=p[i];
            k=i;
        }
    }
    swap(p[k],p[0]);
    sort(p+1,p+n,cmp);

//    if(n==1)
//    {
//        top=0;
//        Stack[0]=0;
//        return ;
//    }
//    if(n==2)
//    {
//        top=1;
//        Stack[0]=0;
//        Stack[1]=1;
//        return ;
//    }
//    if(n>2)
//    {
//        top=1;
//        for(int i=0; i<=1; i++)
//            Stack[i]=i;
//        for(int i=2; i<n; i++)
//        {
//            while(top>0&&mulit(p[Stack[top-1]],p[Stack[top]],p[i])<=0)
//                top--;
//            top++;
//            Stack[top]=i;
//        }
//    }
}
int main()
{
    int n=0;
    while(scanf("%d%d",&p[n].x,&p[n].y)!=EOF)
        n++;
    tb(n);
    int k;
    for(int i=0; i<n; i++)
    {
        if(p[i].x==0&&p[i].y==0)
        {
            k=i;
            break;
        }
    }
    for(int i=k; i<n; i++)
        printf("(%d,%d)\n",p[i].x,p[i].y);
    for(int i=0; i<k; i++)
        printf("(%d,%d)\n",p[i].x,p[i].y);
    return 0;

}

代碼2:簡潔的極角排序(注意排序是從第二個點開始排,第一個點是原點)


/*
題目大意:

思路:
*/
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<cstdio>
#include <vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll unsigned long long
#define inf 0x3f3f3f
#define esp 1e-8
#define bug {printf("mmp\n");}
#define mm(a,b) memset(a,b,sizeof(a))
#define T() int test,q=1;scanf("%d",&test); while(test--)
#define Test() {freopen("F:\\test.in","r",stdin);freopen("F:\\test1.out","w",stdout);}
const int maxn=2e4+10;
const double pi=acos(-1.0);
const int N=110;
const ll mod=1e9+7;
struct point
{
    int x,y;
} p[maxn];
int mulit(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
bool cmp(point a,point b)
{
    point p0;
    p0.x=0,p0.y=0;
    int x=mulit(p0,a,b);
    if(x>0)
        return true;
    return false;
}
int main()
{
    int n=0;
    while(scanf("%d%d",&p[n].x,&p[n].y)!=EOF)
        n++;
    sort(p+1,p+n,cmp);///第一個是(0,0)點
    for(int i=0; i<n; i++)
        printf("(%d,%d)\n",p[i].x,p[i].y);
    return 0;

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章