Reversing Linked List【我不配】

02-线性结构3 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10e​5​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

参考链接

https://blog.csdn.net/liyuanyue2017/article/details/83269991

浙大数据结构习题笔记:02-线性结构3 Reversing Linked List (25分))

我写了很久,题目弄错了好几次,以为和我之前写的题目一样呢,结果怎么改都不对,类似的题目之前见过,这个更复杂。

3-5 单链表分段逆转 (20分)

【10】链表去重【加油啊】

大佬写的正确的答案:

#include<bits/stdc++.h>
using namespace std;
#define max 100000
int main() {
   
   
	int data[max];
	int next[max];
	int list[max];
	int firstAdd,n,k;
	cin>>firstAdd>>n>>k;
	for(int i=0; i<n; i++) {
   
   
		int x,y,z;
		cin>>x>>y>>z;
		data[x]=y;
		next[x]=z;
	}
	int sum=0;
	while(firstAdd!=-1) {
   
   
		list[sum++]=firstAdd;//记录下了连续的地址
		firstAdd=next[firstAdd];//下一个节点的地址
	}
	for(int i=0; i<sum-sum%k; i=i+k) {
   
   
		for(int j=0; j<k/2; j++) {
   
   
			int t=list[i+j];
			list[i+j]=list[i+k-j-1];
			list[i+k-j-1]=t;
		}
	}
	for(int i=0; i<sum-1; i++)
		printf("%05d %d %05d\n",list[i],data[list[i]],list[i+1]);
	printf("%05d %d -1\n",list[sum-1],data[list[sum-1]]);
	return 0;
}

在这里插入图片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章