Hdu1718-Rank


Rank

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5052 Accepted Submission(s): 1978


Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.

Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

Output
For each test case, output a line giving Jackson’s rank in the class.

Sample Input
20070101
20070102 100
20070101 33
20070106 33
20070103 22
0 0

Sample Output
2

20070101 20070102 100 20070101 33 20070103 22 20070106 33 0 0

Sample Output
2


把類做成結構體的形式~



import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
       Scanner sc = new Scanner(System.in);
       while(sc.hasNext()){
    	   String str = sc.next();
    	   Student []a = new Student[1000];
    	   int index=0;
    	   int score=0;
    	   int sum=0;
    	   while(true){
    		   String id = sc.next();
    		   int mark = sc.nextInt();
    		
    		   if(id.equals("0") && mark==0){
    			   break;
    		   }
    		    a[index++] = new Student(id,mark);
    		   if(a[index-1].id.equals(str)){
    			   score = a[index-1].mark;
    		   }
    	   }
    	 
    	   for(int i=0;i<index;i++){
    		   if(a[i].mark>score){
    			   sum++;
    		   }
    	   }
    	   System.out.println(sum+1);
       }
       
	}

}
class Student{
	public String id;
	public int mark;
	Student(String id,int mark){
		this.id=id;
		this.mark=mark;
	}
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章