Hdu1170 Balloon Comes!

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28744 Accepted Submission(s): 10830


Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.

Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input
4 + 1 2 - 1 2 * 1 2 / 1 2

Sample Output
3 -1 2 0.50

題意:輸入t表示有t組數據,然後就是兩個數字的運算。


心得:本來不想把這道題寫到這裏來的,因爲水,但做着做着發現了一些知識上的漏洞,所以決定把寫下來。

            這道題,我是用Java寫的,第一次提交WA,以爲是要hasNext(),改了以後提交,TLE,又測試了一下,發現除得到整數的情況有問題,原來Java中的Double型都是帶小數點的,1就是1.0,這點原來還真沒注意,於是判斷了一下,如果結果是整數就用int相除,否則用結果爲double型。也可以先取餘判斷是否能除盡。


import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
         Scanner sc = new Scanner(System.in);
         int t = sc.nextInt();
         
         while(t-->0){
        	 String str = sc.next();
        	 int a = sc.nextInt();
        	 int b = sc.nextInt();
        	 double sum=0;
        	 if(str.equals("+")){
        		 System.out.println(a+b);
        	 }else if(str.equals("-")){
        		 System.out.println(a-b);
        	 }else if(str.equals("*")){
        		 System.out.println(a*b);
        	 }else if(str.equals("/")){
        		 sum=a*1.0/b;
        		 int sum2 = a/b;
        		 if(sum2==sum){
        			 System.out.println(sum2);
        		 }else{
        			 System.out.printf("%.2f",sum);
        			 System.out.println();
        		 }
        	 }
        	 
         }
	 
	}

}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章