Maximum Product(暴力)

Description

Download as PDF

Problem D - Maximum Product

Time Limit: 1 second

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.


Problem setter: Sérgio Queiroz de Medeiros


AC代碼

#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
    int num[100000];
    int h = 1, n;
    while(cin >> n)
    {
        for(int i = 0; i < n; i++)
        {
            cin >> num[i];
        }
        long long maxn = 0;
        for(int i = 0; i < n; i++)
        {
            long long product = 1;
            for(int j = i; j < n; j++)
            {
                product *= num[j];
                if(product > maxn)
                {
                    maxn = product;
                }
            }
        }
        printf("Case #%d: The maximum product is %lld.\n\n", h++, maxn);
    }

    return 0;
}


















發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章