poj-2387 Til the Cows Come Home dijkstra

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists. Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1


題意:給你T條邊,求從1到n的最短路,直接使用dijkstra最短路算法。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#define ll long long
#define ld long double
#define INF 0x3f3f3f3f
using namespace std;
int map[1002][1002],vis[1002],dis[1002];
void dijkstra(int n){
	memset(vis,0,sizeof vis);
	memset(dis,0x3f,sizeof dis);
	for(int i=2;i<=n;i++){
		dis[i]=map[1][i];
	}
	dis[1]=0;
	for(int i=1;i<=n;i++){
		int min=INF,k=1;
		for(int i=1;i<=n;i++){
			if(!vis[i]&&dis[i]<min){
				min=dis[i];
				k=i;
			}
		}
		vis[k]=1;
		for(int i=1;i<=n;i++){
			if(!vis[i]&&(dis[k]+map[k][i])<dis[i]){
				dis[i]=dis[k]+map[k][i];
			}
		}
	}
}
int main(){
	std::ios::sync_with_stdio(false);
	// freopen("in.txt", "r", stdin);
    // freopen("out.txt", "w", stdout);
    int T,n;
	cin>>T>>n;
	int a,b,c;
	memset(map,0x3f,sizeof map);
	for(int i=0;i<T;i++){
		cin>>a>>b>>c;
		map[a][b]=map[b][a]=min(map[a][b],c);
	} 
	dijkstra(n);
	cout<<dis[n]<<endl;
	return 0;
} 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章