zju 1006 zoj 1006

Do the Untwist

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Cryptography deals with methods of secret communication thattransform a message (the plaintext) into a disguised form (theciphertext) so that no one seeing the ciphertext will be ableto figure out the plaintext except the intended recipient.Transforming the plaintext to the ciphertext is encryption;transforming the ciphertext to the plaintext is decryption.Twisting is a simple encryption method that requires that thesender and recipient both agree on a secret key k, which is apositive integer.

The twisting method uses four arrays: plaintext and ciphertextare arrays of characters, and plaincode and ciphercode arearrays of integers. All arrays are of length n, where n is thelength of the message to be encrypted. Arrays are origin zero, so theelements are numbered from 0 to n - 1. For this problem allmessages will contain only lowercase letters, the period, and theunderscore (representing a space).

The message to be encrypted is stored in plaintext. Given a keyk, the encryption method works as follows. First convert theletters in plaintext to integer codes in plaincode according tothe following rule: '_' = 0, 'a' = 1, 'b' = 2, ..., 'z' = 26,and '.' = 27. Next, convert each code in plaincode to anencrypted code in ciphercode according to the following formula: for alli from 0 to n - 1,

ciphercode[i] = (plaincode[ki mod n] - i) mod 28.

(Here x mod y is the positive remainder when x is divided by y.For example, 3 mod 7 = 3, 22 mod 8 = 6, and -1 mod 28 = 27. Youcan use the C '%' operator or Pascal 'mod' operator to computethis as long as you add y if the result is negative.)Finally, convert the codes in ciphercode back to letters inciphertext according to the rule listed above. The final twistedmessage is in ciphertext. Twisting the message cat using the key 5yields the following:

Array 0 1 2
plaintext 'c' 'a' 't'
plaincode 3 1 20
ciphercode 3 19 27
ciphertext 'c' 's' '.'

Your task is to write a program that can untwist messages,i.e., convert the ciphertext back to the originalplaintext given the key k. For example, given the key 5 andciphertext 'cs.', your program must output the plaintext 'cat'.

The input file contains one or more test cases, followed by a linecontaining only the number 0 that signals the end of the file.Each test case is on a line by itself and consists of the key k, aspace, and then a twisted message containing at least one and at most 70characters. The key k will be a positive integer not greater than300. For each test case, output the untwisted message on a lineby itself.

Note: you can assume that untwisting a message always yieldsa unique result. (For those of you with some knowledge of basic numbertheory or abstract algebra, this will be the case provided that thegreatest common divisor of the key k and length n is 1, which it will be for all test cases.)

Example input:

5 cs.
101 thqqxw.lui.qswer
3 b_ylxmhzjsys.virpbkr
0

Example output:

cat
this_is_a_secret
beware._dogs_barking


這題主要的問題在於如何求plaincode,由題中的公式可得plaincode[ki mod n] =(ciphercode[i]+i) mod 28,通過循環把每一個求出來即可


#include<iostream>
#include<string>
using namespace std;
char plaincode[28];
int plain[1000];
int main(){
    string ciphertext,plaintext;
    int key,n,ciphercode[1000];
    plaincode[0]='_';
    plaincode[27]='.';
    for(int i=1;i<27;i++){
        plaincode[i]=i+'a'-1;
    }
    while(cin>>key,key){
        cin>>ciphertext;
        n=ciphertext.size();
        for(int i=0;i<n;i++){
            for(int j=0;j<28;j++){
                if(plaincode[j]==ciphertext[i]) ciphercode[i]=j;
            }
        }
        plaintext="";
        for(int i=0;i<n;i++){
            plain[key*i%n]=(ciphercode[i]+i)%28;
        }
        for(int i=0;i<n;i++){
            plaintext+=plaincode[plain[i]];
        }
        cout<<plaintext<<endl;
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章