zju 1003 zoj 1003

Crashing Balloon

Time Limit: 2 Seconds      Memory Limit: 65536 KB

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.  The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!"the two players, who each starts with a score of  "1", race to crashthe balloons by their feet and, at the same time,multiply their scores by the numbers written on the balloons they crash. After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numberson the balloons he\she's crashed.  The unofficial winner is the player whoannounced the highest score.

Inevitably, though, disputes arise, and so the official winner is notdetermined until the disputes are resolved.  The player who claimsthe lower score is entitled to challenge his\her opponent's score.  Theplayer with the lower score is presumed to have told the truth, becauseif he\she were to lie about his\her score, he\she would surely come up with a biggerbetter lie.  The challenge is upheld if the player with the higherscore has a score that cannot be achieved with balloons not crashed by thechallenging player.  So, if the challenge is successful, the playerclaiming the lower score wins.

So, for example, if one player claims 343 points and the other claims49, then clearly the first player is lying; the only way to score 343 isby crashing balloons labeled 7 and 49, and the only way to score 49 is by crashinga balloon labeled 49.  Since each of two scores requires crashing theballoon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims81, it is possible for both to be telling the truth (e.g. one crashes balloons2, 3 and 27, while the other crashes balloon 81), so the challenge would notbe upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are tellingthe truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon islikely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculationsthat refereeing requires.  Hence the need for you, sober programmer,to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, thatare claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that theplayer with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
62


這題我想了好長時間都沒有什麼非常好的算法,我的想法是把所有因子提出來,然後針對那些因子作什麼處理不是很清楚,最後搜到一種比較直觀比較好理解的算法,是用回溯做的,如果之前因爲這題煩惱挺長時間的人看了應該會有收穫,其實挺簡單的。


#include<stdio.h>

int flag1,flag2;

int dfs(n,m,fac){
    if(m==1) flag2=1;
    if(m==1&&n==1) {
        flag1=1,flag2=1;
        return 0;
    }
    if(fac<2) return 0;
    if(!(n%fac)) dfs(n/fac,m,fac-1);
    if(!(m%fac)) dfs(n,m/fac,fac-1);
    dfs(n,m,fac-1);
}

int main(){
    int n,m,tmp;
    while(scanf("%d%d",&n,&m)!=EOF){
        flag1=0,flag2=0;
        if(m>n){
            tmp=n;
            n=m;
            m=tmp;
        }
        dfs(n,m,100);
        if(flag1||!flag2) printf("%d\n",n);
        else if(!flag1&&flag2) printf("%d\n",m);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章