1081. 检查密码

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点".",还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(<=100),随后 N 行,每行给出一个用户设置的密码,为不超过80个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出“Your password is wan mei.”;
  • 如果密码太短,不论合法与否,都输出“Your password is tai duan le.”;
  • 如果密码长度合法,但存在不合法字符,则输出“Your password is tai luan le.”;
  • 如果密码长度合法,但只有字母没有数字,则输出“Your password needs shu zi.”;
  • 如果密码长度合法,但只有数字没有字母,则输出“Your password needs zi mu.”。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

==================================================================================================

思路:(话说又出新题了啊233)

使用C++的STL很方便。这题第三个测试点有个坑:题目没说密码不含空格!

所以要用getline,注意用getchar吃掉n后的空格

(本来还想这题会不会在像“.......”这种密码上有坑,然而应该没有,不过代码还是考虑了这点)

#include <iostream>
#include <iomanip>
#include <stdio.h>
#include <stdlib.h>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#define INF 999999999
#define MAXN 105
using namespace std;

int main()
{
    int n,i,len;
    string str;
    cin>>n;
    getchar();
    while(n--)
    {
        str.clear();
        bool dig=false,alp=false,luan=false;
        getline(cin,str);
        len = str.size();
        if(len < 6)
            cout<<"Your password is tai duan le."<<endl;
        else
        {
            for(i=0;i<len;++i)
            {
                if(isdigit(str[i]))
                    dig = true;
                else if(isalpha(str[i]))
                    alp = true;
                else
                {
                    if(str[i] != '.')
                        luan = true;
                }
            }
            if(luan == true)
                cout<<"Your password is tai luan le."<<endl;
            else
            {
                if(alp==true)
                {
                    if(dig == true)
                        cout<<"Your password is wan mei."<<endl;
                    else
                        cout<<"Your password needs shu zi."<<endl;
                }
                else
                {
                    if(dig == false)
                    {
                        cout<<"Your password needs zi mu."<<endl;
                        cout<<"Your password needs shu zi."<<endl;
                    }
                    else
                        cout<<"Your password needs zi mu."<<endl;
                }
            }
        }
    }
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章