POJ1068題(s括號串可有兩種表示,p和w)

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24751 Accepted: 14559

Description

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S       (((()()())))
P-sequence      4 5 6666
W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
題目意思:s串是一串括號,可有兩種表示,p和w,當用p的時候,每個數記錄的是當前右括號之前有多少個左括號。
當用w的時候,每個數記錄的是當前右括號前與之匹配且沒有和其他右括號匹配的左括號編號,當然,此編號是相對於右括號來說的。
代碼如下:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define maxn 200
using namespace std;
int a[maxn];//用來模擬記錄括號,也就是還原s原本的序列
int v[maxn];
int main()
{
    int t;
    int n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(a,0,sizeof(a));
        memset(v,0,sizeof(v));
        int i, j;
        int x;//要輸入的p序列
        int t=0;//記錄當前左括號的數目
        int index=1;//記錄當前括號的下標;
        for(i=0;i<n;i++)
            {
                cin>>x;//每次輸入一個右括號,同時補全左邊括號
                if(x>t)
                {
                    int temp=x-t;//記錄當前的左邊還需要填多少個左括號
                    t=x;
                    while(temp--)
                    {
                        a[index++]=0;//補右括號
                    }
                }
                a[index++]=1;//補左括號
            }
         int flag = 0;
        int num = index; // 總的括號數目
        //for(int i = 1; i < num; i++) printf("%d ", a[i]); printf("\n");
        for(int i = 1; i < num; i++) // 從前往後遍歷 )
        {
            if(a[i] == 1)
            {
                flag = 0;
                int ans = 0;
                for(int j = i-1; j >= 1; j--) // 從後往前匹配,碰到一個沒被訪問的就匹配,輸出答案,然後標誌以訪問,下一個則要往前遍歷
                {
                    if(flag == 1) break;
                    if(a[j] == 0 && v[j] && flag == 0)
                    {
                         ans++;
                    }
                    else if(a[j] == 0 && !v[j])
                    {
                        ans++;
                        v[j] = 1;
                        printf("%d ", ans);
                        flag = 1;
                        break;
                    }
                }
            }
        }
         printf("\n");
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章