poj1328題(雷達覆蓋小島問題)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34841 Accepted: 7737
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

這裏寫圖片描述
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1
題目意思:有一個笛卡爾座標系,在x軸上會有一些雷達,每個雷達覆蓋範圍爲半徑d的圓,在x軸上方會有一些島嶼,求最少用幾個雷達,可全部覆蓋這些島嶼,若不能覆蓋,則輸出-1。
解題思路:
1.對於每個島嶼,如果它離X軸的距離大於d了,則雷達一定不能覆蓋所有的島嶼。
2.對於每個島嶼,以其爲中心,以d爲半徑作圓,求其與x軸的左右交點。然後對這些島嶼的左交點從小到大排序,然後遍歷。
3.若兩個島嶼的區間有重合,則可用一個雷達覆蓋,也就是前一個島嶼的右交點小於後一個島嶼的左交點,並注意再往後遍歷時,更改比較的值,取前兩個重合島嶼的右交點的較小值。若區間沒有重合,則雷達數加一。
代碼:

#include<stdio.h>//雷達覆蓋問題
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
struct position
{
    double left;
    double right;
}p[1001];
bool cmp(position a,position b)
{
    return a.left<b.left;
}
int main()
{
    int x,y,cnt=1;
    //int flag=0;
    int n,d,i;
    while(scanf("%d %d",&n,&d)!=EOF,n!=0||d!=0)
    {
        int sum=1;
        int flag=0;
        memset(p,0,sizeof(p));
        for(i=1;i<=n;i++)
        {
                scanf("%d %d",&x,&y);
                if(y>d)
                flag=1;
                else
            {
                p[i].left=x-sqrt(float(d*d-y*y));//注意sqrt函數的參數是float或者double類型的
                p[i].right=x+sqrt(float(d*d-y*y));
            }
        }
        printf("Case %d: ",cnt++);
        if(flag)
        {
            printf("%d\n",-1);
            continue;
        }
        else
        {
                sort(p+1,p+n+1,cmp);
                double ans=p[1].right;
                for(i=2;i<=n;i++)
                {
                    if(p[i].left>ans)
                        {
                            sum++;
                            ans=p[i].right;
                        }
                    else
                    {
                        ans=min(ans,p[i].right);
                    }
                }
        }
        printf("%d\n",sum);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章