PKU-3264 Balanced Lineup (RMQ之線段樹)

原題鏈接 http://poj.org/problem?id=3264

Balanced Lineup

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N andQ.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cowi
Lines N+2..N+Q+1: Two integers A and B (1 ≤ABN), representing the range of cows from A toB inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source Code

/*
RMQ (Range Minimum/Maximum Query)問題-------線段樹的應用
*/

#include <iostream>
using namespace std;

struct node {
	int low, high;
	int Max, Min;
	node *leftchild, *rightchild;
};

//先分配內存,然後重複利用
node num[200001];
int index;                  

//new新結點
node * NewNode() {
	node *p = &num[index ++];
	return p;
}

//構建線段樹
node * createSegTree(int low, int high, int *heights) {
	
	node * root = NewNode();
	root->low = low;
	root->high = high;

	//葉子結點
	if (low == high) {
		root->Max = heights[low];
		root->Min = heights[high];
        root->leftchild = NULL;
		root->rightchild = NULL;
	} else {
		int mid = (low + high) / 2;
		
		//左子樹low~mid, 右子樹mid+1~high
		root->leftchild = createSegTree(low, mid, heights);
		root->rightchild = createSegTree(mid + 1, high, heights);
		
		//更新最大值
		if (root->leftchild->Max > root->rightchild->Max) {
			root->Max = root->leftchild->Max;
		} else {
			root->Max = root->rightchild->Max;
		}

		//更新最小值
		if (root->leftchild->Min < root->rightchild->Min) {
			root->Min = root->leftchild->Min;
		} else {
			root->Min = root->rightchild->Min;
		}
	}

	return root;
}

//查詢最大值
int getMax(node * root, int low, int high) {
	
	if (root->low == low && root->high == high) {
		return root->Max;
	} else {
		int mid = (root->low + root->high) / 2;
		if (mid >= high) {
			return getMax(root->leftchild, low, high);
		} else if (mid < low) {
			return getMax(root->rightchild, low, high);
		} else {
			int leftMax = getMax(root->leftchild, low, mid);
			int rightMax = getMax(root->rightchild, mid + 1, high);
			if (leftMax > rightMax) {
				return leftMax;
			} else {
				return rightMax;
			}
		}
	}
}

//查詢最小值
int getMin(node *root, int low, int high) {
	
	if (root->low == low && root->high == high) {
		return root->Min;
	} else {
		int mid = (root->low + root->high) / 2;
		if (mid >= high) {
			return getMin(root->leftchild, low, high);
		} else if (mid < low) {
			return getMin(root->rightchild, low, high);
		} else {
			int leftMin = getMin(root->leftchild, low, mid);
			int rightMin = getMin(root->rightchild, mid + 1, high);
			if (leftMin < rightMin) {
				return leftMin;
			} else {
				return rightMin;
			}
		}
	}
}

int main() {
	int N, Q, heights[50005];
	int i, start, end;
	while(scanf("%d %d", &N, &Q) != EOF) {
		for (i = 1; i <= N; i++) {
			scanf("%d", &heights[i]);
		}

		index = 0;
		node * head = createSegTree(1, N, heights);

		while(Q --) {
			scanf("%d %d", &start, &end);
			if (start == end) {
				printf("0\n");
			} else {
				printf("%d\n", getMax(head, start, end) - getMin(head, start, end));
			}	
		}
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章