HDU 3038 How Many Answers Are Wrong (并查集)


题目:
http://acm.hdu.edu.cn/showproblem.php?pid=3038

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11657    Accepted Submission(s): 4186


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
10 51 10 1007 10 281 3 324 6 416 6 1
 
Sample Output
1

    这题是稍微变化了点的并查集,不仅仅是用并查集记录分组情况了,还需要记录每组一直到右端点含有的数值个数,并不断跟新。

    出现错误信息的判断就是,当输入两个端点时候,如果两个端点的根节点相同,就是他两是一组的,这时候判断数值个数是否正确,如果在已有的左端点数值+w(这段区间加上的数值个数-权值)!=右端点的数值,那一定有错误了,ans++。

wa的原因:find函数直接复制,忘记需要添加更新对应value值了

附ac代码:

#include<iostream>
using namespace std;
const int maxn = 200002;
int par[maxn];   //记录根节点,这题就是每个点区间的最左端的值,如果根节点一样就可以判断是不是有错误
int value[maxn]; //记录每个根节点对应的数值
int find(int x)
{
    if (x != par[x])
    {
        int pre = par[x];
        par[x] = find(par[x]);  //路劲压缩
        value[x] += value[pre];  //对应的值也要改变,根据之前的根节点改变
    }
    return par[x];
}
int main()
{
    int n, m;   //n个数字,m代表问的问题的个数
    while (cin >> n >> m)
    {
        int u, v, w;
        int ans = 0;
         //init
        for (int i = 1; i <= n; i++)
        {
            par[i] = i;
            value[i] = 0;
        }
        while (m)
        {
            m--;
            cin >> u >> v >> w;
            u = u - 1;            //B比A-1大S
            int ru = find(u);
            int rv = find(v);
            if (ru == rv&&value[u] + w != value[v])          
            {
                ans++;
            }
            else if (ru != rv)
            {
                //更新根节点,向左更新
                par[rv] = ru;
                value[rv] = value[u]-value[v] + w;        //更新的都是右边的端点
            }
        }
        cout << ans << endl;
    }

    return 0;
}

勇往直前,自我管理,怀着一颗奋斗的心,永不退怯!
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章