ZJU---Problem Arrangement(狀壓DP)

題目鏈接:Problem Arrangement

Problem Arrangement
Time Limit: 2 Seconds Memory Limit: 65536 KB
The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it’s not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of “interesting value” to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output
For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output “No solution” instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution

題目大意:給你n*n的矩陣代表將第i個,放到第j個需要多少代價,(不能同行,也不能同列)問:代價超過M的情況有多少,輸出a/b(答案要最簡化),a代表一共有多少種方案,b代表有多少種代價超過M 的,沒有就輸出No solution.

思路:狀壓DP,剛學我只能說一下我的理解了。
首先遍歷0-2n1 種的情況,代表當前的狀態,從這個狀態枚舉可以到達的所有狀態即可、

代碼:

#include <cstdio>
#include <cstring>
const int N = 13;
int dp[1<<13][510]; 
int f[N];  
int a[N][N];

void isit()
{
    f[1]=1;
    for(int i=2; i<N; i++)
        f[i]=f[i-1]*i;
}
int gcd(int a,int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}
int main()
{
    int T,m,n;
    scanf("%d",&T);
    isit();
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&a[i][j]);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=0; i<=(1<<n); i++)
        {
            int tmp=0;
            for(int j=1; j<=n; j++)
                if(i&(1<<(j-1)))
                    tmp++;
            for(int j=1; j<=n; j++)
            {
                if(i&(1<<(j-1))) continue;
                for(int k=0; k<=m; k++)
                {
                    if(k + a[tmp+1][j] >= m)
                        dp[i+(1<<(j-1))][m] += dp[i][k];
                    else
                        dp[i+(1<<(j-1))][k+a[tmp+1][j]] += dp[i][k];
                }
            }
        }
        if(dp[(1<<n)-1][m] == 0)
            printf("No solution\n");
        else
        {
            int tm = gcd(f[n],dp[(1<<n)-1][m]);
            printf("%d/%d\n",f[n]/tm, dp[(1<<n)-1][m]/tm);
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章