Need for Speed(二分)

題目鏈接:Need for Speed

Sheila is a student and she drives a typical student car: it is old, slow, rusty, and falling apart. Recently, the needle on the speedometer fell off. She glued it back on, but she might have placed it at the wrong angle. Thus, when the speedometer reads s, her true speed is s+c, where c is an unknown constant (possibly negative).
Sheila made a careful record of a recent journey and wants to use this to compute c. The journey consisted of n segments. In the ith segment she traveled a distance of di and the speedometer read si for the entire segment. This whole journey took time t. Help Sheila by computing c.

Note that while Sheila’s speedometer might have negative readings, her true speed was greater than zero for each segment of the journey.

Input
The first line of input contains two integers n (1≤n≤1000), the number of sections in Sheila’s journey, and t (1≤t≤106), the total time. This is followed by n lines, each describing one segment of Sheila’s journey. The ith of these lines contains two integers di (1≤di≤1000) and si (|si|≤1000), the distance and speedometer reading for the ith segment of the journey. Time is specified in hours, distance in miles, and speed in miles per hour.

Output
Display the constant c in miles per hour. Your answer should have an absolute or relative error of less than 10−6.

Sample Input 1
3 5
4 -1
4 0
10 3
Sample Output 1
3.000000000
Sample Input 2
4 10
5 3
2 2
3 6
3 1
Sample Output 2
-0.508653377

思路:二分,只不過要在分母是負數的時候,讓左端點=mid(這一點直接就崩了,沒想到)。
這一題的差值要小於1e-9,雖然誤差是1e-6。

代碼:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<math.h>
#include<string>
#include<algorithm>
using namespace std;
#define PI acos(-1.0)
#define inf 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;

const double ans=1e-9;
const int maxn=1009;

struct node
{
    int di,si;
}edge[maxn];
int n;
double doo(double f)
{
    double sum=0.0;
    for(int i=0;i<n;i++)
    {
        if((f+edge[i].si*1.0)<=0)
            return inf*1.0;
        else sum+=edge[i].di*1.0/(f+edge[i].si*1.0);
    }
    return sum;
}
int main()
{
    int t;
    while(~scanf("%d%d",&n,&t))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&edge[i].di,&edge[i].si);
        double tt=inf;
        double s=-tt;
        while(tt-s>ans)
        {
            double mid=(s+tt)/2.0;
            if(doo(mid)>t*1.0)
                s=mid;
            else tt=mid;
        }
        printf("%.9lf\n",s);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章