POJ-1979 Red and Black

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 35471   Accepted: 19195

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Japan 2004 Domestic

題意:從符號'@'出發能踩多少個黑塊'.'(不能站在紅塊'#'上),出發點也算一個黑塊。

思路:DFS,從出發點朝四個方向走,只要沒有碰到紅塊且座標合法,可以踩到的黑塊數+1,並把黑塊變成紅塊,避免下一次再訪問,遞歸調用DFS訪問接下來的節點,直到訪問完成或者四面碰壁,結束退出,輸出結果。

#include<iostream>
#include<cstring>
using namespace std;
char graph[20][20]={0};
int i,j,p,q;
int I,J;
int result=0;
void DFS(int p,int q)
{
    if(p>=0 && p<=I-1 && q>=0 && q<=J-1 && graph[p][q]=='.')
    {
        result++;
        graph[p][q]='#';
    }
    else   return ;
    DFS(p-1,q);
    DFS(p,q-1);
    DFS(p,q+1);
    DFS(p+1,q);
}
int main()
{
    while((cin >> J >> I) && I && J)
    {
        result=0;
        memset(graph,0,sizeof(graph));
        for(i=0;i<I;i++)
        {
            for(j=0;j<J;j++)
            {
                cin >> graph[i][j];
                if(graph[i][j]=='@')
                {
                    p=i;q=j;
                    graph[i][j]='.';
                }
            }
        }
        DFS(p,q);
        cout << result << endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章