[kuangbin帶你飛] 專題五 並查集 Is It A Tree? POJ - 1308

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路:我其實就是想臭不要臉的水一發,其實和HDU 1272是一樣的。小希的迷宮 HDU - 1272

代碼:

#include<iostream>
#include<cstdio>
using namespace std;

const int maxn = 1e6 + 666;
bool flag, vis[maxn];
int fa[maxn], num, cnt = 0;

void init(){
    for(int i = 0; i < maxn; i++){
        fa[i] = i;
        vis[i] = 0;
    }
    num = 0;
    flag = true;
}

int getfa(int x){
    return fa[x] = fa[x] == x ? x : getfa(fa[x]);
}

void solve(int x){
    if(!vis[x]){
        vis[x] = 1;
        num++;
    }
}

void merge(int x, int y){
    int xx = getfa(x);
    int yy = getfa(y);
    solve(x);
    solve(y);
    if(xx != yy){
        fa[xx] = yy;
        num--;
    }
    else flag = false;
}

void output(bool flag){
    if(flag)
        printf("Case %d is a tree.\n", ++cnt);
    else
        printf("Case %d is not a tree.\n", ++cnt);
}

int main(){
    int x, y;
    while(scanf("%d %d", &x, &y) && x != -1 && y != -1){
        if(x == 0 && y == 0){
            output(1);
            continue;
        }
        init();
        merge(x, y);
        while(scanf("%d %d", &x, &y), x + y)
            if(flag)
                merge(x, y);
        if(flag && num != 1) flag = 0;
        output(flag);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章