【模擬】HDU 1008 Elevator【題解】

Elevator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71305 Accepted Submission(s): 39169

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41

Author
ZHENG, Jianqiang

題意

這個題的意思就是你要坐電梯,這個電梯每向上前進一層需要花費6s,下降一層需要花費4s。停靠的時候還需要花費5s(大概是用來開門吧)
例如:
從0到4 需要花費 6*(4-0)+5 也就是29s。
但是比較坑爹的是,即使在同一層,比如從4到4 還需要花5s。(⊙o⊙)

AC代碼:

#include<cstdio>
#include<iostream>

long long int sum;

void add(int a,int b){
    if(a<b)
        sum+= (b-a)*6+5;
    else
        sum+= (a-b)*4+5;
}

int main(){
    int tmp1,tmp2;
    int n;
    while(~scanf("%d",&n)&&n){
        sum=tmp2=0;
        for(int i=0;i<n;++i){
            tmp1=tmp2; /*這道題沒必要用數組存儲,兩個變量就可以完成所有的錄入。*/
            scanf("%d",&tmp2);
            add(tmp1,tmp2);
        }
        printf("%lld\n",sum);
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章