POJ - 2823 Sliding Window(單調隊列)

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

#pragma warning (disable : 4996)
#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <cstdlib>
#include <vector>
#include <map>
#include <queue>
#include <cmath>
#include <stack>
#include <algorithm>
#include <cmath>
using namespace std;
int all[1000002];
int mins[1000002];
int maxs[1000002];
int main()
{
	int n, m;
	scanf("%d%d", &n, &m);
	for (int a = 0; a < n; a++)
		scanf("%d", &all[a]);
	deque<int>line;//控制長度
	int len = 0;
	for (int a = 0; a < n; a++)
	{
		if (line.empty())
			line.push_back(a);
		else
		{
			if (all[a] > all[line.back()])
				line.push_back(a);//構造遞增隊列, 使得最前的是最小的
			else
			{
				while (!line.empty() && all[a] <= all[line.back()])//數組不要越界
				{
					line.pop_back();
				}
				line.push_back(a);
			}
		}
		if (line.front() > a - m + 1 && a >= m - 1)//保證判斷的時候已經到達了所判斷區域的最後
		{
			mins[len] = all[line.front()];//注意讓每一個判斷區域都有最小值
			len++;
		}
		while (!line.empty() && line.front() <= a - m + 1)//最前元素超出判斷區域將其刪去
		{
			mins[len] = all[line.front()];
			len++;
			line.pop_front();
		}
	}
//	while (len < n - -m)
//	{
//		mins[len] = all[line.front()];
//		len++;
//	}
	//
	while (!line.empty())
		line.pop_back();
	len = 0;
	for (int a = 0; a < n; a++)
	{
		if (line.empty())
			line.push_back(a);
		else
		{
			if (all[a] < all[line.back()])
				line.push_back(a);
			else
			{
				while (!line.empty() && all[a] >= all[line.back()])
				{
					line.pop_back();
				}
				line.push_back(a);
			}
		}
		if (line.front() > a - m + 1 && a >= m - 1)
		{
			maxs[len] = all[line.front()];
			len++;
		}
		while (!line.empty() && line.front() <= a - m + 1)
		{
			maxs[len] = all[line.front()];
			len++;
			line.pop_front();
		}
	}
	//
	for (int a = 0; a < len; a++)
	{
		printf("%d", mins[a]);
		if (a != len - 1)
			printf(" ");
		else
			printf("\n");
	}
	for (int a = 0; a < len; a++)
	{
		printf("%d", maxs[a]);
		if (a != len - 1)
			printf(" ");
		else
			printf("\n");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章